Chaos Unicorn Day LIVE Discussion


#1

Since Status should be in Chaos Unicorn Day mode right now we need a place to discuss that’s going on.


#2

Anyone got any of them good bootnodes? I tried using https://gist.github.com/jacqueswww/3ddfc5ecfa09ecea702744ab15a2200d but says offline/disconnected on both Desktop and mobile, with no peers connected (desktop).


#3

Here’s what I set up using the docker-compose files in status-go.

  • Bootnode(compose):
    enode://bbdcc75aedfd86bdd8812e412e8e1d99da6bb6faeb93cf9cf9ce79009e9bba416[email protected]34.251.227.15:30403
    
  • Mailserver(compose):
    enode://6fa400daf954a9766aa0bb9a29ac461214fb407a6bc0d805bc6c3f2f9424a047e5bd49656a647ed6334ce7c3c83962a0e2571f0939d641813a9a53f2da65e789:[email protected]:30303
    

#4

Also a fix for which port is exposed by Bootnode from the container(it should be udp):


#5

I’ll put mine up soon and post here and on Twitter, justice let me figure out how to install some monitoring that’ll let me watch bandwidth and cpu/ram use as people connect. Suggestions for that? Ubuntu on ARM


#6

I can’t seem to be able to add a Mailserver on desktop:
cant_add_mailserver_desktop
No, I don’t have any whitespace in that URL.


#7

netdata?
Oh, and geth_exporter for metrics of the Mailserver itself.


#8

Oh that looks perfect, let me try.


#9

should be password after enode id, like poopypoo in enode://55956bad3de0e4bf1464e85621e5317d559e8cebd8226203a8819b5db82f59ee7540c01bee96d02fc4e8b554bdc29487e686a6b49d17cdac400f045426c19dd3:[email protected]:30304


#10

Please try again. Still works for me :wink:


#11

Oh, I see, I didn’t know that was even a thing. What does it do?


#12

Prevents those without it from connecting to you :slight_smile:


#13

That’s the first time I’m hearing of this. I didn’t configure any password for my mailserver, so can I just leave it empty?

Also, doesn’t that kinda defeat the purpose of a public Mailserver?


#14

See here: https://our.status.im/bulletproofing-against-chaos-unicorns-with-status-on-arm/


#15

Mailservers requires a password, by default I believe it is set to status-offline-inbox


#16

You can be crawled with a public node. A basic httpauth pass just prevents the bots from finding you, while you can still include it in the enode and be as public as you want


#17

Oooooh, okay, that makes sense. Thanks.

I see.


#19

Lifesaver, thanks for supporting non-tech contributors like me in setting up!


#20

On the next core dev call, let’s have a little post mortem with lessons learned and observations people have done. Please keep note of things that you think can be improved. Feel free to add these notes to the following doc: https://notes.status.im/W0Kvc1XVSuSlGMxe8y1flg#


Chaos Unicorn Day, April 1 2019 (aka kill our cluster)
#21

I’m connected to both @jakubgs and @jacqueswww mailservers but unable to do anything in the app on desktop. Anyone else with the same issues?

Command line only gives “JSON-RPC client is unavailable” over and over again.