Chaos Unicorn Day LIVE Discussion


#22

sometimes restart of the app helps


#23

Hi everyone, log into for the Townhall starting in 4 mins here: https://zoom.us/j/475989692


#24

Here is the Youtube stream: https://www.youtube.com/watch?v=zPyGHVTe3Q4


#25

Try mine: enode://b7a2fe6c8b53650076cb71b5acfad89a74adb2f123ad21d21e9a6dec733299f03ecc56c82fb814c8d0cac4c685e0ab0f69ab7c105f6127392821088f0dad6612:[email protected]:30304


#26

I checked it with canary and it works!

 $ build/bin/node-canary -log ERROR -mailserver 'enode://b7a2fe6c8b53650076cb71b5acfad89a74adb2f123ad21d21e9a6dec733299f03[email protected]77.216.106.68:30304' && echo SUCCESS!
SUCCESS

Added it to trusted mailservers on mine.


#27

Created my own mailserver on DO too:

enode://1dabf696e734115ecb023eaaf8d9263ba53d24d67aa40750383d75ab4df82669d1572bd732b0dcd90593973e59968ff57911fc61f6c4860e17b3c555c6a75e4d:[email protected]:30303

#28

NICE!

 $  build/bin/node-canary -log ERROR -mailserver 'enode://1dabf696e734115ecb023eaaf8d9263ba53d24d67aa40750383d75ab4df82669d[email protected]165.227.79.62:30303' && echo SUCCESS!                     
SUCCESS!

#29

I think there is a problem with MaxPeers not setting properly I have it set in my config , it always defaults to 25 when I monitor the actual connections?


#30

My mailserver:

enode://8a7839270b6f96e3163596f6c957abcc6cb1cd9872e3ecf09610c1b5d511c721365c6fdddafd3e2e9bbe2d3acc719bf779a970a97033fca10a4c22bd0725bdb1:[email protected]:30303

I altered a file config/cli/fleet-eth.beta.json of status-go to this

<see my last post>

#31

Not sure if I should put the password in “TrustedMailServers”.

Also, maybe we can start using another “Fleet”? Something like “eth.chaos”.

Ah then we can one add eachother trusted mailservers in this fleet.


#32

Adding my own:

enode://f05f9b7460ebc6c0f812981e7ebd837a6b9c29dc952dc922ba32c5ad1b6220ab51cf871e6839262034e6327af4d1ca80e3b88a0866547161d9e14ca47b6ece16:[email protected]:30303


#33

you don’t need passwords in TrustedMailservers


#34

I had to edit that config and set "Rendezvous": false, because there are no RendezvousNodes

Should we fire up one? And a Static node?

Also for what are used each specific node?

  • BootNodes? (tells where are other nodes)
  • TrustedMailservers? (store expired messages)
  • RendezvousNodes ?
  • Static Nodes?

#35

are you able to get things going with your config file? what is docker-compose setup, that of the _assets/compose/mailserver Makefile?


#36

Yes, it runs nice with that config file, but I have to edit the config file in the project (outside of _assets), and then just use whats on status-go/develop branch.

But seems like I am having no success in using my own mailserver to myself.


#37

Hm… nothing seems to connect for me, quite annoying.


#38

here’s my config


{
  "Rendezvous": true,
  "NoDiscovery": false,
  "ClusterConfig": {
    "Enabled": true,
    "Fleet": "eth.beta",
    "BootNodes": [
      "enode://55956bad3de0e4bf1464e85621e5317d559e8cebd8226203a8819b5db82f59ee7[email protected]37.247.116.211:30304",
      "enode://e8a7c03b58911e98bbd66accb2a55d57683f35b23bf9dfca89e5e244eb5cc3f25[email protected]47.91.224.35:30404",
      "enode://436cc6f674928fdc9a9f7990f2944002b685d1c37f025c1be425185b5b1f0900f[email protected]174.138.105.243:30404",
      "enode://7427dfe38bd4cf7c58bb96417806fab25782ec3e6046a8053370022cbaa281536[email protected]104.154.88.123:30404",
      "enode://43947863cfa5aad1178f482ac35a8ebb9116cded1c23f7f9af1a47badfc1ee7f0[email protected]47.52.74.140:30404",
      "enode://5395aab7833f1ecb671b59bf0521cf20224fe8162fc3d2675de4ee4d5636a75ec[email protected]206.189.243.57:30404",
      "enode://ebefab39b69bbbe64d8cd86be765b3be356d8c4b24660f65d493143a0c44f38c8[email protected]35.202.99.224:30404"
    ],
    "TrustedMailServers": [
      "enode://55956bad3de0e4bf1464e85621e5317d559e8cebd8226203a8819b5db82f59ee7[email protected]37.247.116.211:30304",
      "enode://da61e9eff86a56633b635f887d8b91e0ff5236bbc05b8169834292e92afb92929[email protected]47.91.156.93:30504",
      "enode://c42f368a23fa98ee546fd247220759062323249ef657d26d357a777443aec04db[email protected]206.189.243.162:30504",
      "enode://7de99e4cb1b3523bd26ca212369540646607c721ad4f3e5c821ed9148150ce6ce[email protected]35.188.19.210:30504",
      "enode://744098ab6d3308af5cd03920aea60c46d16b2cd3d33bf367cbaf1d01c2fcd066f[email protected]47.89.20.15:30504",
      "enode://7aa648d6e855950b2e3d3bf220c496e0cae4adfddef3e1e6062e6b177aec93bc6[email protected]206.189.243.169:30504",
      "enode://015e22f6cd2b44c8a51bd7a23555e271e0759c7d7f52432719665a74966f2da45[email protected]35.226.21.19:30504",
      "enode://74957e361ab290e6af45a124536bc9adee39fbd2f995a77ace6ed7d05d9a1c7c9[email protected]47.52.255.195:30504",
      "enode://8a64b3c349a2e0ef4a32ea49609ed6eb3364be1110253c20adc17a3cebbc39a21[email protected]206.189.243.168:30504",
      "enode://531e252ec966b7e83f5538c19bf1cde7381cc7949026a6e499b6e998e695751aa[email protected]35.225.227.79:30504"
    ],
    "StaticNodes": [
      "enode://55956bad3de0e4bf1464e85621e5317d559e8cebd8226203a8819b5db82f59ee7[email protected]37.247.116.211:30304",
      "enode://19872f94b1e776da3a13e25afa71b47dfa99e658afd6427ea8d6e03c22a99f135[email protected]35.238.60.236:30305",
      "enode://960777f01b7dcda7c58319e3aded317a127f686631b1702a7168ad408b8f8b761[email protected]47.52.58.213:30305"
    ],
    "RendezvousNodes": [
      "/ip4/174.138.105.243/tcp/30703/ethv4/16Uiu2HAmRHPzF3rQg55PgYPcQkyvPVH9n2hWsYPhUJBZ6kVjJgdV",
      "/ip4/206.189.243.57/tcp/30703/ethv4/16Uiu2HAmLqTXuY4Sb6G28HNooaFUXUKzpzKXCcgyJxgaEE2i5vnf"
    ]
  },
  "AdvertiseAddr": "80.216.102.93",
  "HTTPEnabled": true,
  "HTTPHost": "0.0.0.0",
  "HTTPPort": 8545,
  "APIModules": "eth,net,web3,admin",
  "RegisterTopics": [
    "whispermail"
  ],
  "WhisperConfig": {
    "Enabled": true,
    "EnableMailServer": true,
    "LightClient": false,
    "MailServerPassword": "status-offline-inbox"
  }
}


#39

this works, taking your config and replacing "AdvertiseAddr": with my public IP


#40

Your config lacks the WhisperConfig section which was added in #1434 PR. Pull develop branch and re-create the config.


#41

@igor Your config contains many nodes that are off now, thats why I cleaned up and created another “fleet” with just live nodes.

config/cli/fleet-eth.chaos.json:

<see my last post>

And then I just:
$ export FLEET_NAME="eth.chaos"
and status-go/_assets/compose/mailserver$ make